Linux tiene una importante vulnerabilidad en el ‘RunC’ que afecta a los sistemas operativos derivados de este Dejar un Comentario

Se ha encontrado una grave vulnerabilidad en el ‘RunC’ de Linux que afecta a todos los sistemas operativos derivados de este.

Las vulnerabilidades en el software son algo bastante común y periódicamente se suelen descubrir y trabajar para solventarlo. Ahora se ha descubierto una importante vulnerabilidad dentro de la herramienta ‘RunC’, la cual se utiliza en los sistemas operativos Linux. Mediante este agujero de seguridad, un atacante podría obtener permisos de administración en un servidor, consiguiendo así saltarse el sistema de contenedores del sistema operativo. Hablamos de una vulnerabilidad bastante grave que afecta a sistemas operativos como Docker, Debian, Ubuntu y muchos otros.

Grave vulnerabilidad encontrada en el ‘RunC’ de Linux

Dicha vulnerabilidad se ha catalogado como CVE-2019-5736. Ha sido encontrada por los desarrolladores Adam Iwaniuk y Borys Poplawski, dos investigadores de ciberseguridad que se han encontrado con este problema en sus servidores.

La función ‘RunC’ es una herramienta que se utiliza en Linux en la generación y ejecución de contenedores. Esta es una vulnerabilidad muy importante, debido a que el atacante podría hacer uso de la ejecución de comandos arbitrariamente, y así disponer de acceso de todos los contenedores que hay en el sistema.

Esta vulnerabilidad afecta a una gran cantidad de sistemas operativos basados en Linux, así como servicios en la nube. Debian y Ubuntu, por ejemplo, ya han dicho que son vulnerables a este fallo. Plataformas como Google Cloud, Docker, Kubernets o Amazon Web Services también estarían afectados por este problema de seguridad.

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *